[Mailman-Users] Web admin interface not saving changes

Paul O'Neill poneill at valista.com
Fri Feb 13 22:00:47 CET 2004


 thanks for the hint, we were in fact redirecting requests to https. So
we used  bin/withlist -l -r fix_url on each list to make the base URL
https instead of http. We also set the DEFAULT_URL_PATTERN =
'https://%s/mailman/' and this sorted the issue.

 I think this is one for the FAQ


-----Original Message-----
From: Todd [mailto:Freedom_Lover at pobox.com] 
Sent: 12 February 2004 23:17
To: mailman-users at python.org
Subject: Re: [Mailman-Users] Web admin interface not saving changes

Hash: SHA1

Paul O'Neill wrote:
>  we recently installed mailman version 2.1.4. Installation went fine 
> until we tried to use the web interface to add members to the mailing 
> lists that we created. After submitting the changes the lists were not

> updated with the new members. We then realised that although we could 
> read all the settings we actually couldn't make any changes through 
> the interface.
>  Everything  works fine using the /usr/local/mailman/bin tools we can 
> add members, make changes to lists etc but we need to get the admin 
> interface working so we can allow other users to maintain their lists.
>  We have ensured that we have cookies turned on etc. Nothing is logged

> in the mailman log files and apache shows nothing curious either. I've

> checked through the mailman lists and generally around google and seen

> a couple of other similar issues but nothing with a real resolution.

Are you doing any http redirects by chance?  That's one of the most
common reasons for the admin interface acting this way.

- -- 
Todd        OpenPGP -> KeyID: 0xD654075A | URL: www.pobox.com/~tmz/pgp
Bureaucracy is the enemy of innovation.
    -- Mark Shepherd, former President and CEO of Texas Instruments

Version: GnuPG v1.2.4 (GNU/Linux)
Comment: When crypto is outlawed bayl bhgynjf jvyy unir cevinpl.


More information about the Mailman-Users mailing list