[Mailman-Users] Re: Typeerror bug all over web interface

James T Perkins james at loowit.net
Fri Mar 12 00:51:31 CET 2004

Marco complains out about this:
> In many parts of the web interface I am getting the same mailman bug: It
started when confirming a subscription through the online interface:

>  File "/usr/local/mailman/Mailman/OldStyleMemberships.py", line 312, in
>     self.__mlist.user_options[memberkey] |= flag
>  TypeError: unsupported operand type(s) for |=: 'list' and 'int'

I saw this sort of problem happen too. I had been running mailman on one
server, and then I tar'ed up the contents of the list info and archives
and moved it over to an identically configured computer. Or so I thought.

Things mostly worked well, but I kept getting these type errors. Things
worsened to the point where the Web GUI stopped working, config_list -o
stopped working, list_members -d listname stopped working (although
list_members -r listname still worked).  It turned out they always were
related to member list and list configuration settings.  Ultimately, I

    list_members -r listname > regular.folks
    list_members -d listname > digest.folks
    # the last invocation died with a typeerror
    # may not have gotten everyone
    rmlist listname
    newlist listname
    # went off to the GUI and re-set up the list,
    # free from type errors! then...
    add_members -r regular.folks -d digest.folks listname

And then I told everyone their passwords were changed. Fortunately rmlist
doesn't destroy the list archives.

Magically it appears everything is working now... no more typeerrors.

I suspect that something subtle was broken in a digest member entry for
that list, and it screwed up everything else (it seems config_list -o even
pokes through the member list enough to get a type error).


More information about the Mailman-Users mailing list