[Mailman-Users] Messages not moving fro mail directory to qfiles directory

Jon Carnes jonc at nc.rr.com
Tue Mar 16 02:09:57 CET 2004

On Mon, 2004-03-15 at 10:12, David Miner wrote:
> I am running version 2.1.4 of Mailman.
> It was installed from the FreeBSD port.
> I am running FreeBSD 4.9
> My MTA is sendmail.
> I have installed and configured Mailman 2.1.4.  I have created a list and 
> entered the information in /etc/aliases and run newaliases.
> My /var/log/maillog show incoming mail being passed to Mailman.
> The messages are passed through the system until they reach the 
> /usr/local/mailman/mail directory, then they stop.
> bin/check_perms says no problems.
> Qrunners and mailmanactl are running and show up in ps -aux.
> I have followed all of the steps in FAQ 3.14 Troubleshooting: No mail going 
> out to lists members.
> A search of the mailman archives (because of the way I thin about the 
> problem) either resulted in nothing or too much to search through.
> I scanned the archives month by month back to December 2003 and found nothing.
> Suggestions?
> TIA,
> David

David, have you created any lists successfully (and gotten notification
of their creations)? Did you create the "mailman" list?

So... you've successfully created the mailman list and a test list. You
send to the test list and the MTA (Sendmail) runs the Mailman app
associated with that alias - so the message is now waiting in one of
your ~mailman/qfiles/..  directory's.
  cd ~mailman/qfiles/
  ls *

Can you tell us if there are files there, and which directories they are

If there are no files in the qfiles directory, then either they are
getting processed by the qrunners (so there should be MTA records of the
outgoing mail) or they are not getting to the qfiles directory - so the
mailman post app is not working for the list.

Jon Carnes

More information about the Mailman-Users mailing list