[Mailman-Users] Odd smtp-error

Rich West Rich.West at wesmo.com
Sun Oct 24 01:48:31 CEST 2004

Nope.. looks like the problem is still there, and it is only happening 
with mailman.  I cannot express just how frustrating this is since I 
cannot seem to squeeze any additional information out of mailman.. it 
just seems to be a big black hole.. :(

Prior to removing and re-adding the list, one of the symptoms was that 
mailman would connect to the sendmail server (on the same box), do some 
magic that results in the "DSN: User unknown" error, and then it would 
hang on the connection (or so it would appear).  Restarting sendmail or 
restarting mailman would open up the flood gates again and allow email 
to flow.

Interestingly, though, restarting sendmail would get the email to be 

Once I blew away the test list and recreated it with the same members, 
that symptom went away.

However, it still barfs on my email address with the User unknown.  *sigh*

I would love to take the party-line and say "it's an MTA problem", but 
nothing I can find points to that as the source of the problem.  If it 
were an MTA problem, it would be effecting all other emails to that 
address, not just those that are generated from mailman..

Again, is there any way to "turn up" the logging or something.. 
anything.. within mailman?  The logs, so far, are pretty much useless in 
that they simply echo that DSN error..

I am at a complete loss here.. like I said, I even tried blowing away 
the entire list and rebuilding it from scratch with the same result.  
Either it is a configuration problem on the Mailman side that I have 
missed, or it is something I have overlooked completely on the sendmail 
side (although, this seems unlikely).


> I *think* I might have found my problem.. :)
> After doing some searching in /var/log/messages, I came across that 
> particular message ID, and saw the corresponding DSN error.
> I then hit the net searching with regards to the DSN error, and came 
> across a number of postings suggesting that a hostname might be 
> missing from the local-host-names file with regards to sendmail.
> I checked mine, and low-and-behold, the name of my mailing list server 
> that I defined in my mm_cfg.py file was NOT there.  duh.
> I'm going to keep a close eye on it, but I think I'm ok now..
> Thanks to all for your help!
> -Rich
>> Like I said, it works fine via smtp and the only app complaining is 
>> mailman. :)
>> I don't know how to 'turn up' the logging on mailman in order to dig 
>> further to see what it is doing..
>> Also, the email you sent was direct, via SMTP, to the server.. the 
>> same server that mailman sits on..
>> Not sure where else to look...
>> -Rich
>>> Rich West wrote:
>>>> Interesting.. in investigating another problem, I noticed the 
>>>> following in the smtp-error file:
>>>> Oct 22 12:14:49 2004 (4223) All recipients refused: 
>>>> {'rich.west at wesmo.com': (550, '5.1.1 <rich.west at wesmo.com>... User 
>>>> unknown')}, msgid: <41792EB8.7080309 at wesmo.com>
>>> Doesn't look like a mailman problem,
>>> looks like a smtp problem.
>>> I tried sending directly to this account
>>> via smtp, and it worked fine.
>>> Will need more verbose logging to figure this
>>> out.
>>> Are you sending via the correct relay (wesmo.com)
>>> ?

More information about the Mailman-Users mailing list