[Mailman-Users] Mailman configuration error

Adam G. Garson aggarson at hotmail.com
Wed Oct 27 19:55:47 CEST 2004

Hi -- I'm trying to install Mailman on a Mandrake 10.1 system.  I have new
installations of Python 2.3.4 and GCC 3.4.2 both compiled from source -- no
rpms.  When I run the configure script I get the error quoted below.  This
occurs even as root, so I don't think it's a permission problem.   I've done
everything I can think of but can't resolve the issue.  Can anybody give me
some guidance on how to troubleshoot this one (I'm not a programmer)?
Thanks very much.

Adam Garson

 ***** Distutils is not available or is incomplete for /usr/bin/python
 ***** If you installed Python from RPM (or other package manager)
 ***** be sure to install the -devel package, or install Python
 ***** from source.  See README.LINUX for details

/configure --with-username=adam --with-cgi-gid=webgroup --with-mailhost=nan
nypay.net --with-urlhost=nannypay.net --with-python=/usr/local/lib/python2.3
 checking for --with-python... /usr/local/lib/python2.3
 checking Python interpreter... /usr/local/lib/python2.3
 checking Python version... ./configure: line 1379:
/usr/local/lib/python2.3: is a directory
 cat: conftest.out: No such file or directory
 configure: error:

 ***** /usr/local/lib/python2.3 is too old (or broken)
 ***** Python 2.1 or newer is required
 ***** Python 2.1.3 or better is recommended

More information about the Mailman-Users mailing list