[Mailman-Users] Mailman under Cygwin - won't add list

Ben ben at ahualoa.net
Fri Dec 23 02:01:22 CET 2005

> >So, as far as both Windows and Cygwin should be concerned, 
> >mailman _is_ in the Administrators group.
> But that clearly isn't what's happening. What do you get from
> group Ben
> and
> group mailman

I get "bash: group: command not found"

> If they are in more than one group, I think files they create 
> will be assigned to the first group they belong to.

Files they create are apparently assigned to group "None" in most cases.
(I find that if I use "touch" to create a dummy file, it gets the right
Group owner, but almost all other cases result in "None".)

> >> or create the list via the web create interface.
> >
> >Tried that too.  I get an web page stating "Error: You are not 
> >authorized to create new mailing lists."
> And what did you use for the password? It must be the site 
> password or the list creator password set by bin/mmsitepass.

I tried everything I could think of: the passwords for 'Ben' account,
for the 'mailman' account, for the 'Administrator' account, empty
password, list password.  No matter what I tried, it says "Error: You
are not authorized."

Now i tried setting mmsitepass, and giving the same value in the web
create inteface.  That got past the authorization message, and now says
"Error: Unknown virtual host: localhost".

> >But, it won't be run as the 'mailman' user when it's invoked from 
> >Apache, so that assumption will surely fail, right?
> Well, actually it expects to be run in the mailman group 
> which in your case is the Administrators group. Any files it 
> creates have to be group owned by Administrators.

Since Cygwin regularly sets group to 'None', I think this isn't going to
work.  AFAICT there is no real "None" group, it is a pseudo-group
created my Cygwin's "mkgroup" and "mkpasswd" commands.  I had been
getting around it by manually fixing the group IDs in the /etc/passwd
file, to force user 'mailman' into the 'Administrators' group to match
the reality in Windows, but apparently that is not sufficient to really
convince Cygwin.

> Well, in my case, everything runs as user Mark and group None 
> so everything is in the None group, and it works.

Aha!  Well, maybe that's the only functional workaround!  I will try
re-configure and re-install with "--with-mail-gid=None
--with-cgi-gid=None --with-groupname=None" and see if it gets further.
I suspect, though, that it will still create files with 660 permissions,
which will cause other parts of the code to fail..

> Apache is running as a service presumably in 
> the Administrators group so everything has to be in the 
> Administrators group for things to work.

Right, although Cygwin doesn't fully realize that the service is running
in the Administrators group.

> BTW, did you run bin/check_perms after reconfiguring with 
> --with-groupname=Administrators?

I did, with -f so that it would fix everything up.  Unfortunately it
doesn't avoid the 660 and 'None' problems.

If we finally get through this, I promise to make up a FAQ entry that
really works, unlike the really wrong/outdated one in FAQ entry 5.2.


More information about the Mailman-Users mailing list