[Mailman-Users] Incoming messages are not received in Mailman+ Postfix

roy vinner roypivn at indiana.edu
Tue Jul 26 19:56:07 CEST 2005

John Dennis wrote:
> On Tue, 2005-07-26 at 10:17 -0500, roy vinner wrote:
>>I tried 'ping'ing and received no answer for .
>>My system admin tested it and reported that "nothing is listening on
>>that port:
>>sg at james% telnet nrg.wustl.edu 25
>>telnet: Unable to connect to remote host: Connection refused
>>sg at james% "
> BTW, this really isn't a mailman issue, its postfix, its best to move
> this discussion to a postfix list or better yet visit www.postfix.org
> and read their doc. But let me give you one last set of suggestions:

Very much appreciated. I've installed and run pmfirewall and opened port 
25 for both tcp and udp. Thank you for sticking up with me thus far :-).

> Connection refused typically means the port you're trying to connect to
> (port 25) is blocked by a firewall. It can be blocked in a variety of
> places, either on the machine you're running the server on or by any
> other router in between. 
> BTW, connection refused does not mean nothing is listening on the port.
> To see if something is listening on the port you must go the local
> machine the server is running and either try to connect locally
> # telnet localhost 25

telnet localhost 25
Connected to nrg.wustl.edu (
Escape character is '^]'.
220 nrg.wustl.edu ESMTP Postfix (2.1.4) (Mandrake Linux)
502 Error: command not implemented
501 Syntax: HELO hostname
helo nrg
250 nrg.wustl.edu

> -or-
> examine who is listening on the port using any of a variety of
> networking utilities, such as:
> # netstat -l -n | grep :25
> or
> # netstat -l | grep smtp
> Using the first example:
> # netstat -l -n | grep :25
> tcp        0      0      *                   LISTEN
> tcp        0      0    *                   LISTEN
> This says port 25 is being listened on the localhost (loopback) because
> your loopback is and its listening on which is
> (ficticious net addr).

My output is:
tcp        0      0  *             LISTEN 

> If nothing is listening on the external interface, then is postfix
> running? If so did you restart it after modify inet_interfaces to
> include the external interface?
yes. I've tried sending me after this and it is still not coming 
through. Let me know if I should continue this on the postfix list, or 
install sendmail, or whatever.

Many thanks for your assistance!


More information about the Mailman-Users mailing list