[Mailman-Users] (re-post) smtp failures, please help

Ricardo Kleemann ricardo at americasnet.com
Wed Jun 1 17:23:08 CEST 2005

Thanks for the pointers, Mark.

> Is it only the one list, or is it all moderated lists?

Well I reconfigured the list so that members are not moderated, just to
test... no difference.

Now I'm actually just simply sending email directly to the -owner address,
and I continue to get this syntax error.

> If only the one, I suspect some issue with the
> ricardo1-owner at lists.americasnet.com alias in courier?

Well, the fact that the mailman log is reporting an error is in itself an
indication that the alias is piping the message to mailman. This is what the
alias is doing:
"|/usr/local/mailman/mail/mailman owner ricardo1"

so mailman processes the message, and then reports the syntax error.

> What happens to -owner mail for other, non-moderated lists?

I just tried sending to another list "test", to test-owner... and to my
surprise, it fails with the same error! :-/   This means to me that all my
lists are failing for the -owner address.

> >Is there a way I can manually run the mailman program with debug to try
> >see what's going on in the smtp session ?
> See http://mail.python.org/pipermail/mailman-users/2005-May/044742.html
> for a way to replicate Mailman's sending of mail. Try using
> rcpts = ['ricardo1-owner at lists.americasnet.com']
> in the script in that post, but I doubt you'll get much more
> information than you already get.

Thanks... but does mailman really insert the -owner address in that
transaction, or does it already lookup who the owner is for the list and
insert that address?

Anyone else have any ideas?


More information about the Mailman-Users mailing list