[Mailman-Users] Need help with a mailman archiving issue

Mark Sapiro msapiro at value.net
Fri Oct 7 04:26:15 CEST 2005

Richard Feltham wrote:
>There are no errors in the logs related to archiving.
>If there was a permissions error, wouldn't the arch <listname> fail when run
>as the mailman user? It is running successfully at this time.

Probably, but there are possible pathological cases where it could
succeed and yet the the qrunner process could fail.

>I am getting a large chunk of
>SHUNTING: 1128243796.8916991+691c72ec041f52f3e9395829b8c94be6a13ee3f27
>Uncaught runner exception: unknown encoding
>Traceback (most recent call last):
>in the logs. Not much else.

What is the traceback (or tracebacks if they aren't all the same)
associated with these errors? This may or may not be significant to
your issue.

In any case, you now have a large collection of messages in
qfiles/shunt/. There is a question about what to do about them.
Normally, you would figure out what is causing the messages to be
shunted, fix that and run bin/unshunt to reprocess the shunted
messages, but if these are the 'unarchived' messages, you've already
added (some of) them to the archive with bin/arch so you don't want to
reprocess those.

Please let us see the tracebacks and we may be able to help diagnose
the problem and suggest a course of action.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list