[Mailman-Users] Problem Installing on Solaris 10

Kent Taylor KTaylor at federalworking.com
Mon Apr 3 19:22:37 CEST 2006

Thank you Mark. I get an "option --without-extension not recognized" error.


From: Mark Sapiro [mailto:msapiro at value.net]
Sent: Mon 4/3/2006 1:11 PM
To: Kent Taylor; mailman-users at python.org
Subject: Re: [Mailman-Users] Problem Installing on Solaris 10

Kent Taylor wrote:

>I'm attempting to install Mailman 2.1.8b1 on Solaris 10 - "configure" works - "make" works - "make install" does not. I checked the lists and found that I'm not the only person to have this problem - Unfortunately, the other person's solution was to revert to Solaris 8 - I really don't want to do that. The "make install" error is "command '/sgnome/tools/x86-solaris/forte/SOS8/SUNWspro/bin/cc' failed with exit status 2" trying to compile "src/hangul.c" - Any assistance would be appreciated. Thank you.

I'm only guessing as a workaround that might not work or might cause
other problems, but if you look at misc/Makefile in the unpack
directory, you'll see

SHELL=          /bin/sh
PYTHONLIBDIR=   $(prefix)/pythonlib
                --install-purelib $(DESTDIR)$(PYTHONLIBDIR) \
                --install-data $(DESTDIR)$(PYTHONLIBDIR)
SETUPCMD=       setup.py --quiet install $(SETUPINSTOPTS)
PKGDIR=         $(srcdir)

Try adding a line to SETUPINSTOPTS so it becomes

                --install-purelib $(DESTDIR)$(PYTHONLIBDIR) \
                --without-extension \
                --install-data $(DESTDIR)$(PYTHONLIBDIR)

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list