[Mailman-Users] Can't get list to post messages

Mark Sapiro msapiro at value.net
Wed Apr 12 23:08:31 CEST 2006

Vicki Stanfield wrote:
>I can't seem to get the alias stuff set up right. Here is what I have
>cd /usr/local/mailman
>ran bin/genaliases
>chown mailman:mailman data/aliases*
>chmod g+w data/aliases*
>changed the alias_maps definition in main.cf to:
>alias_maps = hash:/etc/postfix/aliases,

Do you have

MTA = 'Postfix'

in mm_cfg.py? Is the value of POSTFIX_ALIAS_CMD in Defaults.py
('/usr/sbin/postalias') correct for your 'postalias' command, and if
not have you provided the correct path in mm_cfg.py?

>verified that there were actually /etc/postfix/aliases and
>/usr/local/mailman/data/aliases files.

How about /usr/local/mailman/data/aliases.db? As new or newer than

>restarted postfix and mailman
>Tried to send a test mail using mutt, but system just hangs.

What does "just hangs" mean? What did Postfix do with the mail?

>Oh, and I ran newaliases again just for the fun of it.
>Can you see what I am missing here?

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list