[Mailman-Users] Problems Installing from SVN

James Davis jamesd at jml.net
Tue Apr 25 18:16:08 CEST 2006

I'm looking to tweak the source of my mailman installation a little so
decided to install from source onto my Debian system using the
subversion repository. This is the first time I've installed mailman
from source, usually I just rely upon the Debian packages.

Everything installed without a problem, so good so far. But when I go to
view the webpages I get the following error in my browser.

Bug in Mailman version 2.2.0a0

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of
traceback and other system information has been explicitly inhibited,
but the webmaster can find this information in the Mailman error logs.

If I try and start mailman's qrunner I get the following errors.

cressida:/usr/local/mailman# ./scripts/mailman start
Traceback (most recent call last):
  File "/usr/local/mailman/bin/mailmanctl", line 126, in ?
  File "/usr/local/mailman/Mailman/loginit.py", line 94, in initialize
    handler = ReopenableFileHandler(os.path.join(mm_cfg.LOG_DIR, logger))
  File "/usr/local/mailman/Mailman/loginit.py", line 43, in __init__
    logging.FileHandler.__init__(self, filename, mode, encoding)
TypeError: __init__() takes at most 3 arguments (4 given)

Any ideas? I'm using Python 2.3.5.



More information about the Mailman-Users mailing list