[Mailman-Users] "-owner" works, "-admin" doesn't...

Kris Wilk kris at reefnet.ca
Thu Apr 27 03:18:57 CEST 2006

Hi Mark,

Thanks for the detailed info. Much appreciated.

Mark Sapiro wrote:
> Short answer... The -admin address is a synonym for the -bounces
> address.

I discovered this myself just now as I looked at the contents of the 
"admin" and "bounces" scripts in the scripts directory.

> This leads me to think as above that at least some mail from mailman to
> you (like an unrecognized bounce notice or a subscription notice) is
> actually bouncing and it is this secondary bounce that is being
> registered.

Interesting idea...all I know for sure is that no matter what address I 
use as the owner (I've also tried setting it to an off-site gmail 
account), test mails of any format sent to "-admin" do not get to the owner.

Yet sending directly to "-owner" works just dandy.

What's even more weird is that if subscribe notifications go to 
"-owner", how would they bounce and my test messages to "-owner" not?

> Did you start or change the way you reject spam? If you have spam
> filtering, try white listing the -bounces address so notices from
> list-bounces will get through.

I have been using SpamAssasin since before I started using Mailman. But 
to take it out of the equation I turned off SA completely. 
Unfortunately, that didn't help.

Guess I've got some detective work to do! My web host is also 
investigating the issue, but I'm not holding my breath.


More information about the Mailman-Users mailing list