[Mailman-Users] A scrubber issue

Mark Sapiro msapiro at value.net
Sun Dec 10 21:52:21 CET 2006

Todd Zullinger wrote:
>The Mailman README still says the base Python requirement is 2.1.3 or
>above.  I saw in the comments of bug 1099138 that email 2.5 could
>still produce None payloads.  Does that mean it's only save to omit
>the "not part" test if the site's python install carries email 3?

Mailman installs it's own Python email library in pythonlib/email/ and
sets paths so that this library is used in preference to the one in
the Python install.

Mailman 2.1.9 ships with email 2.5.8. The email 2.5.x version at the
time of Barry's comment was 2.5.6. I don't know if the change that
eliminates the None payloads is in email 2.5.8 or not.

I'm inclined to not omit the "not part" test, but rather to change it
in one of the two ways I suggested in

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list