[Mailman-Users] Concerning Build-time options

Mark Sapiro msapiro at value.net
Fri Dec 15 20:05:04 CET 2006

Ryan Steele wrote:
>I've got a Mailman installation that was built on box A.  Box A's 
>default domain is the .priv domain, but that domain is only visible to 
>the internal network.  So, box A's internal domain is .priv to all the 
>internal boxes; to the external boxes, it's A.foo.com.

This can cause confusion about Mailman's add_virtualhost() stuff, but I
don't think that is the issue here. See
and other FAQs it points to for a discussion of these issues, but
that's not your immediate problem.

>I've double-checked, using the config_list utility, that host_name was 
>correct, and it is...I've got "host_name = lists.foo.com".

The visible list attribute host_name is the domain that mailman uses
for all list email addresses.

>Is there 
>some other option I can set within Mailman to change the default 
>domain?  Or is this something I need to fix at the MTA level?  All other 
>mail (e.g., mail not being sent out by Mailman) seems to go out with the 
>correct domain name, but I'm not discounting anything at this point.  

The inconsistency between Mailman mail and other mail is puzzling. Do
both paths send through the same initial MTA?

In any case, if the list's host_name is correct, I don't think it's

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list