[Mailman-Users] Question about postfix-to-mailman.py

Mark Sapiro msapiro at value.net
Tue Dec 19 18:37:17 CET 2006

Barry Finkel wrote:

>I am trying to decide whether to use the Debian/Ubuntu 2.1.5-9ubuntu4.1
>package or to use the 2.1.9 source for Mailman.

I would recommend installing from source, but I'm biased ...

>I see that Ubuntu
>comes with
>     postfix-to-mailman.py
>a Postfix transport pipe.  I do not see this in the 2.1.9 source.
>Is this transport pipe really needed?

No, it is not needed and may or may not be even desirable, depending on
your needs. In order for it to work well, mailman list addresses need
to be in their own domain. It is based on qmail-to-mailman.py and also
functionally similar to mm-handler, both of which are in the
distribution in the contrib/ directory.

The main advantage of these delivery methods is they enable delivery of
mail to Mailman 'automatically' without requiring aliases. However,
Postfix integrates well with Mailman, and Mailman provides automatic
updating of aliases for Postfix.

>Am I correct in assuming that I can use this python module even if
>I install Mailman from the 2.1.9 source?

Yes, you can. 

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list