[Mailman-Users] Mailman replacing subject text with odd characters and tabs

Matt Zorzin zorzin at anc.net
Thu Feb 2 04:43:34 CET 2006

My company runs several mailman lists for internal usage, which we have 
been happy with for years. Recently after an upgrade, our system has 
started behaving strangely.

We have an automated ticket system that occasionally sends out email to 
the lists. This has always worked fine in the past. Lately, it is 
starting to replace spaces in the subject header with odd characters and 
newlines....but only on two of the four lists.

An example: This is a copy/paste of an affected message's header.

Subject: [XXX-List] XXXXX-XXXXX: unit not eligable for warranty
	despite being purchased as new

You'll notice the newline after 'warranty'.

Also, most of the spaces in these subjects are being replaced by 
characters unprintable in Outlook Express or Mozilla; we get little 
black squares in between each word, which indicates some sort of 
character set error.

Only two of our four lists are doing this, and we have checked character 
encodings on all the pages we can find. I have verified with our 
sysadmin that the mailman and internal ticket system lists are set to 
the exact same character set. We see no differences in the 
configurations between the functional and bugged lists.

Does anybody have any suggestions on a course of action to take? I can 
provide more information as it's needed, but I'm kind of inexperienced 
at this and have been tasked with figuring out what's up with our system.

More information about the Mailman-Users mailing list