[Mailman-Users] sendmail and mm-handler woes

Mark Sapiro msapiro at value.net
Mon Feb 13 23:38:19 CET 2006

Kevin McNamee wrote:
>When I send a mail (from Outlook) with DEBUG turned on in mm-handler, I get
>a "Returned mail" with the debug output. So it seems that that is working.
>Without DEBUG it does not reach Mailman moderation. I tried to send the same
>message on the command line:
>> su - mailman
>> cat testmsg.txt | /usr/local/mailman/mail/mailman post testlist
>And this got to the moderation queue. Since the testmsg.txt includes headers
>I also got a message back from testlist-bounces saying that my message was
>awaiting approval.
>When I accept the message, it does not appear in the archive.
>There seems to be two problems here:
>  1) messages not reaching Mailman from Outlook/mm-handler
>  2) approved messages not being archived (or sent to members).
>Perhaps this is just an archiving problem. If the processing steps are
>  moderation -> archiving -> post to members

It's more like ...-> moderation -> queue for archiving -> queue for
delivery with the processing of the archive queue and the outgoing
queue handled by separate processes.

Check all of Mailman's logs.

>Looking at the lists/testlist/digest.mbox I can see that the messages are in
>the file!

The messages from Outlook too?

Try moving the digest.mbox file aside. This shouldn't affect 2.1.7, but
who knows...

>Trying a different approach I created a new list called "foobar"
>and suddenly my test messages to foobar are archived and posted to members!
>Still have a problem sending mail from Outlook. Tried directly with sendmail
>echo "From: kevin.mcnamee<at>symsoft.se
>To: foobar<at>mailman.symsoft.se
>Subject: Test
>test mail body
>" | /usr/sbin/sendmail -v -fkevin.mcnamee<at>symsoft.se
>Still no luck. I will continue testing. Any help appreciated.
>Some comments on the FAQ:
>Step 1) This 
>    ps -aux| grep mailmanctl |grep -v grep
>should be replaced with this
>    ps -ef | grep qrunner |grep -v grep
>Step 3) To locate the smrsh directory try
>    strings /usr/lib/smrsh | grep sm.bin
>Step 4) I ran 'netstat -na |grep ":25 "' but I did not get any result.
>Step 6) This step is confusing. I have lock files and the process that
>created the lock does exist.  Does this step say that I can delete them
>anyway or that I should only delete them if there is no process found?

The FAQ definitely needs updating. It's a community project. Please

Re: step 1, the intent of that author was to check for mailmanctl only.
If you're going to check for qrunners too, you need to change more
than the command. BTW, I use
  ps -fAw | grep 'p[y]thon'

or I just ignore the grep result.

Step 6 is saying that it is safe to remove the lock for your problem
list, but here's an alternate suggestion. Do

  bin/mailmanctl stop

Verify mailmanctl and all runners have stopped. Remove any remaining
locks/* files. then,

  bin/mailmanctl start

This assumes no web server process has a list locked legitimately, but
that's unlikely in your case.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list