[Mailman-Users] Mailman page won't display in browser (usingVPN)

John Fleming john at wa9als.com
Wed Jan 4 02:31:06 CET 2006

----- Original Message ----- 
From: "Mark Sapiro" <msapiro at value.net>
To: "Tristan Colson" <tristan at teslamotors.com>; <mailman-users at python.org>
Sent: Tuesday, January 03, 2006 7:48 PM
Subject: Re: [Mailman-Users] Mailman page won't display in browser 

> Tristan Colson wrote:
>>When I try to invoke our Mailman installation in a browser (Firefox,
>>although it doesn't work in IE either), via our corporate VPN
>>(Netscreen-Remote on Windows XP), instead of displaying the page in the
>>browser, it attempts to download a file.
>> I see the message:
>>You have chosen to open
>>which is a: application/x-httpd-php
>>from: http://mailman.ourcompany.com
>>What should Firefox do with this file?
>>(Note: the filename above is blank)
>>Mailman works fine from directly within our network, it just doesn't
>>work when I am using the VPN. I imagine it has more to do with the VPN
>>than with Mailman, but so far Mailman is the only web application that
>>behaves in this fashion, so I am looking for clues as to what might be
>>causing this behaviour. Seems like some kind of weird MIME-type bug, but
>>I'm not sure what (other PHP applications behave fine within our VPN).
>>Would appreciate any clues...
> I don't know why this would happen with Mailman only, and it does seem
> like a VPN issue or a VPN/web server integration issue.

I've had similar experience from an improperly configured Apache httpd.conf 
when using SSL.  I have no idea how that relates to a VPN, but the result 
was similar, ie it wanted to download a file, so I agree its probably a 
VPN/webserver issue.  - John

More information about the Mailman-Users mailing list