[Mailman-Users] moving mailman

mardin at comcast.net mardin at comcast.net
Thu Jul 13 00:26:48 CEST 2006


Thanks for your help! Both URL and post are working now after following your instructions!

But I met a new problem. After I used URL of https://mailman_server/mailman/admin/, I could log in the list successfully. But I could not modify the contents of configurations and do other administration work. When I wanted to submit the changes, I got the following message:

"Although this page is encrypted, the information you have entered is to be sent over an unencrypted    connection and could easily be read by a third party.
Are you sure you want to continue sending this information? -> Continue"

After I clicked the Continue Botton, nothing changed about the list. What were the problems about the above message? Do you know how to resolve it?


 -------------- Original message ----------------------
From: Mark Sapiro <msapiro at value.net>
> mardin at comcast.net wrote:
> >
> >Please see the errors after moving to the new mailman server with same hostname 
> and IP address:
> >
> >> Didn't work how? What happens when you post to a list? What happens
> >> when you go to that URL?
> >
> >(1) Went to URL (http://mailman_server.domain.net/mailman/admin/) and got 
> errors:
> >
> >Not Found
> >The request URL /mailman/admin/ was not found on this server
> There is a problem in httpd.conf or mailman. Either
> ScriptAlias /mailman/ ...
> doesn't point to the mailman cgi-bin/ directory or it doesn't contain
> the wrappers.
> What does the web server error_log say?
> >(2) Errors of post to the mailing list test at mailman_server.domain.net
> >
> >Jul 11 8:02:20 mailman_server sendmail[5791]: k6BM2ALL005791: 
> from=<mardin at domain.net>, size=418, class=0, nrcpts=1, 
> msgid=<44B41F46.3080604 at domain.net>, proto=ESMTP, daemon=MTA, 
> relay=mardin.domain.net []
> >Jul 11 8:02:20 mailman_server smrsh: uid 8: attempt to use "mailman post test" 
> (stat failed)
> >Jul 11 8:02:20 mailman_server sendmail[5792]: k6BM2ALL005791: 
> to="|/usr/local/mailman/mail/mailman post test", 
> ctladdr=<test at mailman_server.domain.net> (8/0), delay=00:00:00, xdelay=00:00:00, 
> mailer=prog, pri=30624, dsn=5.0.0, stat=Service unavailable
> >Jul 11 8:02:20 mailman_server sendmail[5792]: k6BM2ALL005791: k6BM2ALL005792: 
> DSN: Service unavailable
> Sendmail is using smrsh and is unable to execute the mailman wrapper.
> Do you have a /etc/smrsh directory? Does it contain a symlink from
> 'mailman' to '/usr/local/mailman/mail/mailman'. See item 3) in
> <http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq03.014.htp>.
> -- 
> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list