[Mailman-Users] GID mismatch with Postfix on Fedora Core 5 install of mailman RPM

Todd Zullinger tmz at pobox.com
Wed Jul 26 04:35:46 CEST 2006

Hash: SHA1

Chris Lawson wrote:
> Please excuse what may well be an FAQ but I did search the list
> archive and couldn't get an answer.
> I am running Postfix and Mailman on Fedora Core 5 system.
> I have a bunch of lists that *were* working under Sendmail, but now
> with Postfix, I get a GID mismatch error for the mail wrapper.
> More specifically:
>> Command output: Group mismatch error.  Mailman expected the mail
>> wrapper script to be executed as group "mail", but the system's
>> mail server executed the mail script as group "nobody".  Try
>> tweaking the mail server to run the script as group "mail", or re-
>> run configure,  providing the command line option `--with-mail-
>> gid=nobody'. )
> Is there a way of getting the RPM version of mailman to expect a
> different mail wrapper GID?

This isn't really an rpm issue.  It's a difference between sendmail
and postfix.  Postfix will execute the wrapper script using the group
of the alias file where the wrapper command is defined.

Are your list aliases kept in the system-wide alias file or in a
mailman-specific alias file?  I've used the postfix integration that
is built in to mailman for ages and find that it's very convenient.

See section "6.1.1 Integrating Postfix and Mailman" in the
installation manual for complete details.  The manual is available on
FC5 at:


> If I try to tweak the mail server (change main.cf to run as nobody)
> postfix fails. The process that's failing (local) already has the
> privileged flag set in master.cf.
> What am I missing? Or do I have to delete the RPM install and
> install  from source --with-mail-gid=nobody?

No need to do that.  The rpm's should work.  I've used them

- -- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
I would like to electrocute everyone who uses the word "fair" in
connection with income tax policies.
    -- William F. Buckley

Version: GnuPG v1.4.4 (GNU/Linux)
Comment: When crypto is outlawed bayl bhgynjf jvyy unir cevinpl.


More information about the Mailman-Users mailing list