[Mailman-Users] A glitch in Mailman??

Tom Ray tom at detroitonline.com
Fri Mar 24 16:58:53 CET 2006


OK, I really think I messed this up so any help you or anyone can give
would be great. I'm going to try to give as much detail as possible this
time around because I've done some digging and I think I see where the
problem is but I don't know how to get around it. Basically, I believe I
screwed up. And now I have customers getting a bit peeved because they
can't add or manage their Mailman lists via the website. They are being
told the site doesn't exist, even though the list is running flawlessly.
So not everything is broken, just the web interface. Like I said before
under the Mailman Icon, instead of have the proper release number they
all say 2.1.7 so you were right about all of them reading some place

I have five different domains running Mailman installations. Also, three
of the five domains are each running with different releases of Mailman
2.1.x. The first site was installed using 2.1.5, the second with
2.1.6rc3, the third with 2.1.6, and the last two were with 2.1.7. Sites
one through three where configured with the following:

./configure --prefix=/home/virtual/sitename.com/mailman
--with-python=/usr/bin/python --with-username=mailman
--with-groupname=mailman --with-cgi-gid=nobody --with-gcc=no

Each site had the scripts/mailman copied to
/etc/rc.d/init.d/sitename-mailman then I ran chkconfig --add

Before site four was installed I had upgraded python to 2.2 and made
/usr/bin/python a softlink to /usr/bin/python2.2 and then configured the
site like so:

./configure --prefix=/home/virtual/sitename.com/mailman
--with-python=/usr/bin/python2.2 --with-username=mailman
--with-groupname=mailman --with-cgi-gid=nobody --with-gcc=no

Again, I copied scripts/mailman to /etc/rc.d/init.d/sitename-mailman and
ran chkconfig --add sitename-mailman. Up to this point everything was
working great. All the sites could manage their lists via their web
interface, the Version number was correct per site. The trouble started
when site number five was installed. Unfortunately, an associate here
removed the installed directory I had created for site five so I can not
check the config.status from my ./configure command but I follow a
pretty simple path when doing this installs so I can only assume I did
it just like site four above.

Site five is the only site with a working web interface, but I believe
it's the root cause of all the problems. After it was installed all the
web interfaces for the other four sites basically broke saying there
where no lists installed on them even if you called on them directly.
And like you had said, upgrading site one to 2.1.7 did not help. While
the lists are running the web interface is still not working, except I
found this little tidbit of information.

I recreated the sitewide mailing list by doing the  bin/config_list -i
data/sitelist.cfg mailman and then running bin/mmsitepass [password] and
bin/mmsitepass -c [password]. If I call on the mailman list directly in
the web interface I can manage it and it appears (it's just not public),
however, when I go to create a new list via the web interface it tells
me I am not authorized to create a list even though I'm using the
password I set via bin/mmsitepass -c. So I decided to give something a
shot and I used the list creator password from site five and got the
"unknown virtual hosts" error that time around. Some how, some way site
five became the granddaddy of the other four sites. When I try to create
a list on any of them it appears to accept the password but then dies
because their virtual host information is not in mm_cfg.py.

Now here's where it gets funky for me. I changed the Virtual Host
information in site five to match site one and tried to setup the list
again via the web interface and it worked! The list was created. Now it
gets even funkier, when I go to http://lists.siteone.com/mailman/admin
it shows the list I just created but not any of the current lists
running under that site. When I go to
http://lists.sitefive.com/mailman/admin it does not show that list, but
if I call on it directly via site five it prompts me for the password. 

Finally, when I run bin/list_lists under site one it lists all the
current mailing lists but not the new one I just created. When I run
bin/list_lists under site five it shows all of site five's lists AND the
new one I created.

I apologize for this being long and drawn out but I wanted to make sure
all the details where here. So I have two questions: 1) Is there a work
around to fix this? And 2) If not, can I back up the data, archives, and
lists files for each site and then remove all installations of Mailman,
do all fresh installs then copy the backed up data into the proper spots
on the fresh installs?

I just need to get the web interfaces working and do it without causing
a heaving downtime impact on the lists that are running now.

Thanks for any and all help!

> -----Original Message-----
> From: Mark Sapiro [mailto:msapiro at value.net] 
> Sent: Friday, March 17, 2006 4:40 PM
> To: Tom Ray; mailman-users at python.org
> Subject: Re: [Mailman-Users] A glitch in Mailman??
> Tom Ray wrote:
> >I'm running mailman on multiple sites (virtual mail server) and for 
> >each installation I configured it for the domain inquestion 
> only. The 
> >last two installs that I did were with mailman 2.1.7 while 
> the existing 
> >ones were with 2.1.6. It appears that the mailing lists for all the 
> >domains are working just fine but I'm running into a problem 
> with the 
> >web site side of it all.
> >
> >All the domains installed with 2.1.7 are _not_ having any 
> issues with 
> >the web interface. However, all the domains setup with 2.1.6 are not 
> >working. It claims there are no public lists to view and 
> when I enter 
> >the list to view (per the page's instructions) I'm being 
> told the list 
> >doesn't exist. It also says that the installed version is 2.1.7
> >
> >Is there something I missed? I was under the impression that if I 
> >configured each domain seperately it would not be an issue. 
> Do I need 
> >to run some sort of upgrade script on the sites using 2.1.6?
> This shouldn't be a 2.1.6 vs. 2.1.7 issue. It's hard to know 
> what's goin on from your description, but is seems your 
> separate installs are not as separate as you think.
> Is each domain's set of cgi-bin wrappers in it's own cgi-bin 
> directory, and were each domain's wrappers compiled by a 
> makefile configured with its own unique set of 'prefix' arguments?
> Were the 2.1.6 lists created in their current domains? If not 
> see 

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list