[Mailman-Users] Web archive problems...

Mark Sapiro msapiro at value.net
Thu Mar 30 01:17:47 CEST 2006

Daniel F Moisset wrote:
>ARCHIVE_TO_MBOX = 2 (actually set on Defaults.py)
>I have also set values for PUBLIC_EXTERNAL_ARCHIVER and
>PRIVATE_EXTERNAL_ARCHIVER to use also a secondary archiver.

I'm not actually sure whether this is a bug or an error (a bug is fixed
by changing the code; an error is fixed by changing the documentation
- or vice versa; it's an old joke, and I don't remember for sure).

In any case, the description of the settings for ARCHIVE_TO_MBOX in
Defaults.py does not agree with what the code does.
*_EXTERNAL_ARCHIVER is an either/or situation. If you specify an
external archiver, it is used instead of the built in Pipermail
archiver, not in addition to.

This is apparently because the description of the ARCHIVE_TO_MBOX
settings predates the addition of the *_EXTERNAL_ARCHIVER settings.
The NEWS file states under Mailman 1.1

    - New configuration variables PUBLIC_EXTERNAL_ARCHIVER and
      PRIVATE_EXTERNAL_ARCHIVER which can contain a shell command
      string for os.popen().  This can be used to invoke an external
      archiver instead of the bundled Pipermail archiver.  See
      Defaults.py for details.

Thus, it appears that the behavior is intentional.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list