[Mailman-Users] mailman and postfix - postfix works, but mailman doesn't

John Durkin john.durkin at gmail.com
Thu Mar 30 21:43:21 CEST 2006

We have compiled and installed per the instructions mailman using
postfix as the MTA.  We can send mail fine using postfix command-line.
 Also, the first few times we would get errors in the maillog about
the gid.  We read up on that and have fixed it.  But - now when
mailman should be sending notifications, etc - it does not.  No errors
appear in the maillog either.  Our aliases seem fine.  I even tried
something else which produced interesting results...

Reading the aliases list, I tried this:

/usr/local/mailman/mail/mailman owner johnlist

johnlist is a list i made successfully.  i can make lists, subscribe
people, etc. through the httpd interface to mailman and command-line.

so - anyway - the first time i ran the above command, i received on my
console the very same error we were getting in the beginning - about
how the mail wrapper was being run by an unexpected user (in the way
we are configured, it expects mailman to run it.)  So, I su to
mailman, run the command again like so:

/usr/local/mailman/mail/mailman owner johnlist

and it behaves almost as if i were running commandline mail email at address.com

so i type "Test" and hit ctrl-D and it exits, no errors, etc.  But -
still I get no mail.

Any input welcome!!!


More information about the Mailman-Users mailing list