[Mailman-Users] PGP keys causing problems

Mark Sapiro msapiro at value.net
Thu May 18 01:22:34 CEST 2006

Todd Zullinger wrote:
>Jeff DeReus wrote:
>> I have enabled the content_filter and added mime_types to see if
>> this will solve my little problem.
>> application/pgp-signature
>> multipart/signed
>Let us know if it does.  I'm not really familiar enough with the code
>to know if it will help.  I don't think it will, but I could easily be

Depends on whether Content Filtering is on or off. If off, nothing in
pass_mime_types has any effect - everything is passed. If on, these
are necessary or the whole message will be filtered out.

>> I am probably using the wrong word in the wrong place here.
>> Everything is displayed properly in the mbox for the list.  It is
>> only the archive that is affected.
>That's good to know.  Unfortunately, I don't know enough about how the
>archive scrubber code works to know how to solve the problem.
>Hopefully someone else can offer some help.

There are issues with the archiver with respect to certain, complex
structures, but here are some points.

The entire message was in the .mbox file for the list. This means the
entire message was delivered to message subscribers and MIME format
digest subscribers. A scrubbed message is in the archive and was
delivered to plain digest subscribers.

Before giving up on the archive, look at the 'source' html of the
archive page and look at the 'source' of the scrubbed attachment(s).
I've seen scrubbed attachments that look like X is missing when viewed
in browser A and look like Y is missing when viewed in browser B, when
in fact, if you look at the actual file, everything is there.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list