[Mailman-Users] Still can't send out from Mailman

Mark Sapiro msapiro at value.net
Fri Oct 27 01:16:16 CEST 2006

Dr. Scott S. Jones wrote:
>I changed my mm_cfg.py to read as last two lines: 
>SMTPHOST = 'localhost'

This does no harm, but putting those lines in mm_cfg.py doesn't really
do anything as you are just resetting them to the same values they
already have from Defaults.py.

>I have since run /etc/init.d/mailman restart, which responded as follows: 
>fyrenice:/etc# /etc/init.d/mailman restart
>Restarting mailman queue runner: mailmanShutting down Mailman's master
>No child with pid: 17469
>[Errno 3] No such process
>Stale pid file removed.
>Starting Mailman's master qrunner.

This indicates that Mailman may have been improperly shut down in the
past (maybe from your crash?). Now, do 'ps -fAw | grep python' or
however you spell that on your system. You should see exactly one
mailmanctl process and exactly 8 qrunner processes with names
ArchRunner, BounceRunner, CommandRunner, IncomingRunner, NewsRunner,
OutgoingRunner, VirginRunner and RetryRunner. If this is not what you
see, see
for a procedure that will clean things up.

Also, are you still getting the same smtp-failure entries when Mailman
sends, and are you getting any log messages from smtplib in Mailman's
'error' log?

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list