[Mailman-Users] Infamous error "ImportError: ld.so.1: python: fatal: libgcc_s.so.1" (solved)

Rolf E. Sonneveld R.E.Sonneveld at sonnection.nl
Thu Apr 5 16:20:10 CEST 2007

Tokio Kikuchi wrote:
> Rolf E. Sonneveld wrote:
>> Tokio Kikuchi wrote:
>>>> However, when I try to access Mailman via my browser (using Apache 
>>>> on the server side) I get the infamous error message:
>>>> The /usr/local/lib version seems to be more recent. Before 
>>>> installation, I made sure that LD_LIBRARY_PATH was set to     
>>> So, the apache was not running under LD_LIBRARY_PATH envrironment.  
>>> You should setenv LD_RUN_PATH while compiling or use crle.  Read the 
>>> crle man for detail.
>> as a followup to my previous message: I just did a ldd for httpd and 
>> this is the result:
>> bash-3.00# ldd /usr/local/apache/bin/httpd
> It's not httpd which caused that error.  Maybe its python and/or a 
> module which resides in python library path (.../lib/python2.x/) which 
> is called from httpd running environment.  You should set LD_RUN_PATH 
> properly while compiling python, mailman, and httpd.  LD_LIBRARY_PATH 
> is only effective when the compiled executable is running.  So, you 
> might want to startup httpd like:
> # LD_LIBRARY_PATH=/whatever/lib /some/where/bin/apachectl start

Great! I removed Python and Mailman, recompiled again using the proper 
LD_RUN_PATH (in addition to the LD_LIBRARY_PATH) and now it works like a 
charm. I didn't have to recompile Apache. Thanks a lot for your help!


More information about the Mailman-Users mailing list