[Mailman-Users] Server migration problems

Aaron Crosman acrosman at afsc.org
Fri Apr 27 18:24:30 CEST 2007

> -----Original Message-----
> From: Mark Sapiro [mailto:msapiro at value.net]
> Sent: Thursday, April 26, 2007 10:31 PM
> To: Aaron Crosman; mailman-users at python.org
> Subject: Re: [Mailman-Users] Server migration problems
> ----- Original Message ---------------
> Subject: [Mailman-Users] Server migration problems
>    From: "Aaron Crosman" <ACrosman at afsc.org>
>    Date: Thu, 26 Apr 2007 14:22:19 -0400
>      To: <mailman-users at python.org>
> >I know this comes up all the time, but having carefully reviewed the
> >and archives, I still haven't been able to solve my problem.
> >
> >
> >
> >I'm working on migrating my mailman setup from an old SuSE server to
> >new Debian (4.0) server.  For the most part everything has gone
> >smoothly, but the existing lists have a couple of problems I can't
> find
> >the cause.  I  moved the lists, archive, and data directories from
> >old server, and ran update, check_perms and check_db on all the
> >
> >
> >
> >If I run list_lists, mailman sees all the lists just fine, but when
> just
> >the web interface I don't see anything.  I naturally assumed that had
> >somehow become private during the move, so I exported the
> configuration
> >of one of them, and saw "advertised = True" and while I know in
> >it shouldn't matter, I went ahead and updated it to be "advertised =
> 1",
> >no difference.  If I browse to the list's admin interface directly it
> >seems to work.
> This certainly seems like FAQ 4.62 to me
> Have you run fix_url?
> >I'm also having trouble getting into the archives.  The files are
> there,
> >and the sym-links are correct but the permissions seem to be wrong.
> And what are they? And what's in the web server's error log?
> >I'm
> >assuming I'm having a problem similar to the advertising (that mm
> seems
> >to be over-tightening permissions somewhat), but I can't find the
> >cause.  Any suggestions on where to look?
> Look at the permissions and whether the web server is allowed to
> symlinks, and if all that is OK, it might be a SeLinux or other kind
> of security polict issue.
> --
> Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
> San Francisco Bay Area, California    better use your sense - B. Dylan

Thanks, you were right on about the domain problem.  I looked right
passed it, since the server will end up at the same domain, but
currently I'm accessing by IP address (I hosts file update on my local
machine solved that problem).

The archives problem persists.  You gave me the right place to look here
as well.  The archives are all owned by list (group list), but the
private archives have restricted access that blocks other users from
getting in:  
ls of /var/lib/mailman/archives:
drwxrws--- 200 list list 8.0K 2007-04-25 14:26 private
drwxrwsr-x   2 list list 4.0K 2007-04-25 14:23 public

A sample from the private directory is:
drwxrwsr-x  4 list list 4.0K 2007-04-25 14:18 itd_test

Apache's error log:
[Fri Apr 27 11:42:14 2007] [error] [client] Symbolic link
not allowed or link target not accessible:
/var/lib/mailman/archives/public/itd_test, referer:

I can't browse the file system (in bash) to those directories.  I did
double check the links in public as root, and they do work just fine, so
I'm at a permissions problem.  What should the perms here be?  Or am I
missing something else?


More information about the Mailman-Users mailing list