[Mailman-Users] more help with mailman configure and GID

Christopher Adams adamsca at gmail.com
Wed Aug 29 21:10:25 CEST 2007

Okay, another migration, another GID problem. I configured mailman to
run as mail GID=mailman (which is 502) and cgi-gid = apache (which is
48). The configuration and installation went fine and check_perms
showed no problems.

Setting up lists works okay. However, when I try to send a mesage to
the list, I get this:

 test7 at myserver.com on 8/29/2007 11:36 AM
            Failed (Command died with status 8:
"/usr/local/mailman/mail/mailman post test7". Command output: Failure
to    find group name for GID 1004.  Mailman expected the mail wrapper
to be    executed as group "mailman", but the system's mail server
executed the    wrapper as GID 1004 for which the name could not be
found.  Try adding GID    1004 to your system as "mailman", or tweak
your mail server to run the    wrapper as group "mailman".)

Why is it looking at mailman GID=1004 when it is 502? Mailman UID is
1004, but not GID.  I tried reconfiguring it with mail GID = nobody,
which I have done before, but still get this message.

Help is most welcome.

Christopher Adams
adamsca at gmail.com

More information about the Mailman-Users mailing list