[Mailman-Users] check_perms question

John Fleming john at wa9als.com
Sat Dec 29 23:00:04 CET 2007

Running 2.1.9 on Debian etch (stable), lists working fine except qrunner 
silently dies and noone notices until someone realizes they haven't seen any 
mail lately.  Currently worked around with cron job restarting Mailman. 
Googling around, some have suggested this might be related to 

Whether my perms are related to the above problem or not, I apparently do 
have some permissions problems as shown by running check_perms.  There were 
initially 70-some problems, most if not all of which were related to group 
being root instead of list.  I ran check_perms -f (as root) and many, but 
not all, were fixed.  Now there are 17 that still show having the same 
problem - group root not list - and I can't seem to fix it.  Even using 
WinSCP and trying to change the group ownership with that instead of 
check_perms -f does not give lasting results.  IOW, I can't seem to change 
the permissions!

I'm not a Linux expert, obvious from the above...  Any suggestions?  Would 
CHMOD from a server terminal be any different?  Any other comments?  I've 
checked the FAQ, but I don't see the problem there (or don't recognize it).

Thanks!  Running Mailman since 2.1.5 with essentially no problems until I 
upgraded Debian from sarge to etch and Mailman from 2.1.5 to 2.1.9.

Thanks!  - John

More information about the Mailman-Users mailing list