[Mailman-Users] Mail stuck in qfiles/in

Allan Trick atrick at prin.edu
Fri Feb 2 17:45:23 CET 2007

Our Mailman 2.1.5 system (on a Red Hat Linux server w/sendmail) 
hasn't been working all week.  I just discovered it, and the first 
thing I did was ./mailmanctl restart ---

It appears to have done what I told it:

Feb 02 09:43:31 2007 (1541) Master watcher caught SIGINT.  Restarting.
Feb 02 09:43:31 2007 (1549) RetryRunner qrunner caught SIGINT.  Stopping.
Feb 02 09:43:31 2007 (1549) RetryRunner qrunner exiting.
Feb 02 09:43:31 2007 (1541) Master qrunner detected subprocess exit
(pid: 1549, sig: None, sts: 2, class: RetryRunner, slice: 1/1) [restarting]
Feb 02 09:43:31 2007 (6814) RetryRunner qrunner started.

Then I sent a message to list 'testlist2' - it appears to have been 
sent (this is from the maillog file):

Feb  2 10:22:52 www sm-mta[9248]: l12GMpDR009246: 
to="|/var/mailman/mail/mailman post testlist2", 
ctladdr=<testlist2 at prin.edu> (8/0), delay=00:00:01, xdelay=00:00:00, 
mailer=prog, pri=30512, dsn=2.0.0, stat=Sent

But it wasn't posted.  The last post to any list was:

Jan 29 20:09:51 2007 (29673) post to 2018 from 
angie.wohlfarth at prin.edu, size=3180, 
message-id=<B66B90CC472EF54C9BAEB1E98C9D7CE80104894E at ss-exc-01.principia.local>, 

There are 30 or so messages in qfiles/in waiting to be sent.  The 
oldest ones looked rather large, so I moved them out of that 
directory and sent another message to my testlist.  Still nothing.

Any suggestions?


More information about the Mailman-Users mailing list