[Mailman-Users] Best version of Python to use with Mailman

vancleef at lostwells.net vancleef at lostwells.net
Wed Feb 14 02:30:27 CET 2007

The esteemed Brad Knowles has said:
> Use the latest version of 2.4.x.  As you've demonstrated, the 2.5 
> stuff is not yet fully baked, and Mailman 2.1.8 and earlier are not 
> compatible with it.  $DEITY-only-knows what else they're going to 
> break in the process of trying to "fix" 2.5.
> I'll update the FAQ Wizard to reflect this.
Thanks for the feedback.  

I think that for Mailman purposes, the good news is that the partial
build of Python 2.5 using Sun's C compiler has been online
"production" for several weeks and hasn't crashed yet.  However, after
assessing the Python build situation, I think that a back-down to
2.4.4 would be wise.

I did post details of what I've done with the Python 2.4.4 and 2.5
build trees to the python-help mail list.  What I got was a suggestion
to take it to the python-dev list, which I've done.

At this point, either I'm missing something pretty basic and
reinventing the wheel, or I've smoked out some long-standing issues
with Python build-install, not all of which are specific to Solaris.


More information about the Mailman-Users mailing list