[Mailman-Users] Python Requirement

Mark Sapiro msapiro at value.net
Thu Jan 18 21:25:38 CET 2007

Patrick Bogen wrote:

>On 1/18/07, maillists <lists at gmnet.net> wrote:
>> Is it OK to keep Python my 2.2.?  Am I headed for trouble at all? I
>> still need a push to jump off this cliff.
>You fool! You'll doom us all with your Python 2.2 foolishness!
>Ahem. That said, I don't know of any problems with python 2.2, but
>others may know better.
>I guess this is a production box? Any chance you could build a test
>box (vmware image?), install the newest mailman with python 2.2 on
>that, and test it?

See the reply (to one of maillist's earlier posts) at

Also see <http://wiki.list.org/display/DEV/Mailman+2.1>.

Mailman 2.1.9 et seq requires Python 2.3. In 2.1.9, the work-around is
not too difficult, but it will only get worse. Mailman 2.2 will
require Python 2.4.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list