[Mailman-Users] mailman install problem

Piniella, David A DPiniella at med.miami.edu
Tue Jan 23 23:11:40 CET 2007


Hmmm, that didn't work. Same error about no cc...

-----Original Message-----
From: Hank van Cleef [mailto:vancleef at bronze.lostwells.net] 
Sent: Tuesday, January 23, 2007 4:52 PM
To: Piniella, David A
Cc: mailman-users at python.org
Subject: Re: [Mailman-Users] mailman install problem

The esteemed Piniella, David A has said:
> I have actually already renamed the /usr/ucb/cc (to cc_old) and
modified my path (specifically for the install):
> bash-3.00# which gcc
> /opt/csw/gcc3/bin/gcc
> bash-3.00# which cc
> no cc in /usr/local/sbin /opt/csw/sbin /opt/sfw/sbin /opt/sbin 
> /usr/sbin /sbin /usr/local/bin /usr/bin /opt/bin /bin /usr/openwin/bin

> /opt/csw/bin /opt/sfw/bin /usr/apache/bin /opt/csw/gcc3/bin 
> /usr/ccs/bin
> bash-3.00#
> I'm still getting the same "unable to execute cc" error. I really
don't understand it; would there be any cached info?

Hokay! Here's the deal.  I have just walked this question through with a
junk Mailman 2.1.9 tree.  This tree was originally build using Studio 11
cc.  I took the pointer to that out of my PATH, ran a make clean, and
ran configure.  It crashed at what appears to be the same point yours

Then I ran a make distclean, and reran configure.  That ran to
completion properly.  Followed that up with a make, although that
doesn't compile the stuff in the misc directory.  However, checking that
makefile it has CC=gcc.

I'll suggest that you start over with a make distclean and a new


Hank van Cleef (vancleef at lostwells.net, hvanclee at nyx.net)
1986 420SEL "A stranger in paradise" (Fremont Co. Wyoming)
1986 GMC 1500 6.2 diesel pickup "Seen one, seen them all"

More information about the Mailman-Users mailing list