[Mailman-Users] Problems Exim: Child process of mailman_transport transport returned 2

sascha.kaempf at arcor.de sascha.kaempf at arcor.de
Thu Jan 25 15:51:27 CET 2007

Hi list,

I have just installed Mailman and run into a problem i can not understand:

2007-01-25 15:47:41 1HA5t7-0005Xc-Gb ** listname at myserver R=mailman_router T=mailman_transport: Child process of mailman_transport transport returned 2 from command: /usr/local/mailman/mail/mailman

Mails can not be delivery to Mailman. I´m using Mailman 2.1.9 in combination with Exim 4.63.

The problem has been, that the mail-gid was different, than what Mailman expected:

Group mismatch error.  Mailman expected the mail
wrapper script to be executed as group "mail", but
the system's mail server executed the mail script as
group "root".  Try tweaking the mail server to run the
script as group "mail", or re-run configure,
providing the command line option `--with-mail-gid=root'.

So I did a make clean followed by:

./configure --with-mail-gid=mail --with-cgi-gid=www-data --with-mail-gid=root
i also tried
./configure --with-mail-gid=mail --with-cgi-gid=www-data --with-mail-gid=0
followed by make install.

Both should work, no ?

h1055564:/tmp/mailman-2.1.9# cat /etc/group | grep root

Once done I stopped Exim & mailmanctl and started both applications again.

Still, I receive the error mentioned above but I can not find any mistake:

h1055564:/tmp/mailman-2.1.9# /usr/local/mailman/bin/check_perms -f
Keine Probleme aufgetreten
h1055564:/tmp/mailman-2.1.9# /usr/local/mailman/mail/mailman post
post script got no listname.

Any idea? Perhaps it is a stupid error I´ve just overlooked but I run out of ideas -;(


More information about the Mailman-Users mailing list