[Mailman-Users] Looping Moderator Approval Requests / Mailman&Exim

Mark Sapiro msapiro at value.net
Fri Jul 27 17:51:20 CEST 2007

Mike Peachey wrote:

>Mark Sapiro wrote:
>> This is the problem. Exim is piping mail to listname-owner at example.com
>> to "| /path/to/mail/mailman/ post listname" and it should be piped to
>> "| /path/to/mail/mailman/ owner listname".
>But surely, that would affect a single separate e-mail sent directly to 
>list-owner@ ? If I send to that address, delivery succeeds to the 
>correct recipients.

OK. But then why does your email to listname-owner get properly
delivered to the owners, but Mailman's mail to listname-owner get
delivered to the list?

>> It is an exim configuration problem.
>Still possible, but I'm having trouble seeing how.

The configuration excerpt you posted below looks correct, but perhaps
there is prior router that only applies to mail from localhost that
uses an alias or something else and delivers to the list. Is 
mailman_router the FIRST defined router?

I now notice in your original post you said "I have configured the Exim
transport/router as directed to pipe all mail into mailman that hasn't
been caught by aliases instead." This suggests mailman_router is not
first and some other router which ignores the -owner suffix is routing
this mail.

mailman_router should be the first router.

Also, you might check your exim-main-log to see how these messages are
routed and delivered.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list