[Mailman-Users] Not getting aliases, owner notification on newlist

Jock Coats jock.coats at jcsolutions.co.uk
Tue Mar 27 12:59:40 CEST 2007

Hi all, hope someone can help...

I've been using Mailman 2.1.6 for some time now that I happily  
compiled and installed from source on my own server.  Now I've needed  
to move to another server and at first I took the opportunity to  
upgrade to 2.1.9.  But the OutgoingRunner NEVER worked - logging is  
not very verbose for all of this but when I tried running it manually  
- qrunner -v -r Outgoing I got "segmentation fault".

Now I'm running a pretty standard Debian Sarge setup so I thought I'd  
try the Debian package, which is 2.1.5.  Now at least the Outgoing  
qrunner is starting and staying up but, when I created my first, and  
any subsequent lists, I do not get the list of four or five aliases  
before the prompt saying "hit return to notify the list owner" nor,  
when I do hit return, do I get notified of my new list.

What can I tell you...I'm using Postfix as my MTA and virtual domains  
(though this problem seems to occur whether I use the default domain,  
as for the site-list or any of the virtual domains, so I haven't got  
as far as editing the mailman-virtuals database yet as I don't seem  
to have gone that far yet.

I did follow through the FAQ entry 3.14.  Check_perms did find  
problems (of course I hadn't actually run that as I would with an  
install I had compiled myself).  I, naturally, installed the package,  
using aptitude, running as root, and all the symlinks in /var/lib/ 
mailman pointing at /usr/lib/mailman/* had group root, instead of  
group list, and check_perms -f was not able to fix those so I did so  

I then deleted and recreated the site-list and still got the same  

I notice in the logs/error I seem to get:

Mar 27 08:19:14 2007 (22935) Master qrunner detected subprocess exit
(pid: 26312, sig: 11, sts: None, class: OutgoingRunner, slice: 1/1)  
Mar 27 08:19:14 2007 (26757) OutgoingRunner qrunner started.

Every time it tries to send a message - that one coincided with me  
deleting and recreating the site list.

Can I get more verbose output than that?

There's nothing left over in the qfiles directories, though both in  
and out are shown as modified at the same time as that OutgoingRunner  
error above.

I watch my postfix logs while I am doing all this and see absolutely  
nothing.  If I try to send a message either to the site list, or to  
mailman-owner, it shows up in the postfix logs passing it onto the  
post command and deleting it from the postfix queues after which it  
just seems to get lost, neither coming back out to the 'real' mailman- 
owner nor getting syphoned off in shunt or anything like that - just  
quietly dying.

Any thoughts?

TIA, Jock

Jock Coats
Warden's Flat 1e, J Block Morrell Hall, OXFORD, OX3 0FF
w: +44 (0)1865 483353 h: +44 (0)1865 485019
m: +44 (0)7769 695767 e: jock.coats at jcsolutions.co.uk
www: http://jockcoats.blogspot.com/

More information about the Mailman-Users mailing list