[Mailman-Users] problem under gentoo

Luo Hei luo_hei at yahoo.es
Thu Oct 18 18:20:41 CEST 2007

After reinstalling my system (migrated from Centos to Gentoo 2007.0) I 
made a big mistake. I overwrote gentoo /etc/passwd file with my old one 
to restore my user list. After that I tried to install mailman and found 
alot of problem. First, mailman ebuild has a fixed number for mail group 
(280) instead of detecting it. I had to manually change group numbers to 
match it and reinstall postfix. After that, the build installed 
correctly, but doesnt works. When I use the start script simply fails 
without leaving any message. I run mailman and it starts ok, but when a 
mail is sent to any mailing list I get this error mail:
Command died with status 2:
"/usr/local/mailman/mail/mailman post red-admin". Command output: Group
mismatch error. Mailman expected the mail wrapper script to be executed as
group "postfix", but the system's mail server executed the mail script as
group "nobody". Try tweaking the mail server to run the script as group
"postfix", or re-run configure, providing the command line option

How can I fix this?
http://dsgp.blogspot.com | Linux, programación, juegos
Have no place I can be since I found Serenity
But you can’t take the sky from me

LLama Gratis a cualquier PC del Mundo. 
Llamadas a fijos y móviles desde 1 céntimo por minuto. 

More information about the Mailman-Users mailing list