[Mailman-Users] mailman not delivering messages

Mark Sapiro msapiro at value.net
Sun Sep 9 18:08:12 CEST 2007

dario luzzi wrote:

>I recently installed mailman 2.1.9 and postfix on a debian machine.
>I'm having problems in getting it to work as I'm a newbie but hope
>someone can help :-)
>I tried searching for a solution on various documents but now I'm more
>confused than before
>After I created a test list with two subscribers and tried to send a
>mail I see this message in mail.log:
>Sep  9 17:30:03 unabomber postfix/smtpd[20305]: connect from
>Sep  9 17:30:03 unabomber postfix/smtpd[20305]: E721E1A44F1:
>Sep  9 17:30:04 unabomber postfix/cleanup[20309]: E721E1A44F1:
>message-id=<aab0687e0709090834y5b9b3aey3331a85bdd2cd45 at mail.gmail.com>
>Sep  9 17:30:04 unabomber postfix/qmgr[20261]: E721E1A44F1:
>from=<myself at gmail.com>, size=1796, nrcpt=1 (queue active)
>Sep  9 17:30:04 unabomber postfix/pipe[20310]: E721E1A44F1:
>to=<direttivo at lists.domain.net>, relay=mailman, delay=1,
>delays=0.61/0.02/0/0.41, dsn=2.0.0, stat
>us=sent (delivered via mailman service)

And what is this "mailman service"?

>Sep  9 17:30:04 unabomber postfix/qmgr[20261]: E721E1A44F1: removed
>and this is my main.cf file
>#added for mailman
>#virtual_maps = hash:$config_directory/virtual,
>virtual_maps =  regexp:/etc/postfix/virtual-regexp
>relay_domains = lists.domain.net gmail.com
>transport_maps = hash:/etc/postfix/transport
>#mailman_destination_recipient_limit = 1

Evidently your transport_maps above is realying to the 'mailman'
transport, but what is that?

Usually, with Postfix, Mailman-Postfix integration is configured per

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list