[Mailman-Users] mailman 2.1.11 install problem

CJ Keist cj.keist at colostate.edu
Thu Aug 21 20:13:04 CEST 2008

Just solved it!!  When we were installing a separate piece of software, 
namely Teralis Helpdesk package, we were forced to upgrade all packages 
from blastwave.org.  This upgraded  python to 2.5.1 which I guess is not 
supported with mailman yet?  Anyway I found that there is a older 
version of python, 2.3.3 in /usr/sfw/bin.  So set that in in my 
configure line:

./configure --prefix=/userM/mail-services/mailman2 
--with-python=/usr/sfw/bin/python --with-cgi-gid=15

make install
went through!!!!

CJ Keist wrote:
> Mark,
>    Thank you.  I did find the following messages:
> http://www.mail-archive.com/mailman-users@python.org/msg43260.html
> http://www.mail-archive.com/mailman-users@python.org/msg43262.html
> http://www.mail-archive.com/mailman-users@python.org/msg35645.html
> But nothing is working, they seem to make sure your env path is set 
> right. This is what I have set:
> /usr/ccs/bin:/usr/sfw/bin:/usr/local/bin:/opt/csw/bin:/usr/bin:/usr/sbin
> I don't have access to Sun Studio compiler so that option is out for 
> me.  I'm using python from blastwave.org version 2.5.1
> Mark Sapiro wrote:
>> CJ Keist wrote:
>>> One more thing,
>>>    I just tried to link cc to gcc but then get the following when I 
>>> try to install:
>>> cc: language arch=v8 not recognized
>>> cc: src/_japanese_codecs.c: linker input file unused because linking 
>>> not done
>>> cc: build/temp.solaris-2.10-sun4v-2.5/src/_japanese_codecs.o: No 
>>> such file or directory
>>> error: command 'cc' failed with exit status 1
>>> *** Error code 1
>>> make: Fatal error: Command failed for target `install-packages'
>>> Current working directory /space/src/mailman-2.1.11/misc
>>> *** Error code 1
>>> The following command caused the error:
>>> for d in bin cron misc Mailman scripts src templates messages tests; \
>>> do \
>>>     (cd $d; make DESTDIR= install); \
>>> done
>>> make: Fatal error: Command failed for target `doinstall'
>> That's a twist. Usually it's the Korean codecs that cause a problem,
>> but see
>> <http://mail.python.org/pipermail/mailman-users/2008-June/062275.html>
>> for some info on the solaris install.
>> Also, there's lots more in the archives. you can try sifting through
>> <http://www.mail-archive.com/search?q=solaris+install&l=mailman-users%40python.org> 
>> or refining that search.

C. J. Keist                     Email: cj.keist at colostate.edu
UNIX/Network Manager            Phone: 970-491-0630
Engineering Network Services    Fax:   970-491-5569
College of Engineering, CSU
Ft. Collins, CO 80523-1301

All I want is a chance to prove 'Money can't buy happiness'

More information about the Mailman-Users mailing list