[Mailman-Users] Upgrading rpm mailman from mailman source

Paul opensource at unixoses.com
Sun Dec 21 00:05:03 CET 2008

I tried yesterday unsuccessfully from upgrade mailman-
on Centos 4 to the latest 2.1.11 from sourceforge.

When I ran "configure" it said I needed to install Python from source or
install the Python-devel package, so I installed the python-devel.

# yum -y install python-devel

Then "configure" said my mailman package path was not in
"/usr/local/mailman", which it is not, it is in "/usr/lib/mailman".

So, within the unpackaged mailman 2.1.11 dir, I did a global replace to
put my path in there:

# perl -pi -e 's/usr\/local\/mailman/usr\/lib\/mailman/g' `find ./ -type f`

Then "configure" ran successfully, then ran "make", then "make install". 
All seemed to go well.  I did "check_perms" and fixed permissions. started
up mailman "service mailman start", and all seemed to be running fine, but
now none of my lists showed "lists_lists".  My "mm_cfg.py" was untouched. 
Being in a hurry because I didn't alert any of the lists members of
downtime, I freaked out and restored my system.  Luckily I just did a full
backup of my LVM, so booted up via live CD and restored the LVM from the
dump file and was back online.

Is there anything special to do when updating from source?  I've usually
done it from RPM packages.  Any pointers?  Thanks.

More information about the Mailman-Users mailing list