[Mailman-Users] check_perms question

Mark Sapiro mark at msapiro.net
Wed Jan 2 22:20:47 CET 2008

John Fleming wrote:

>Running 2.1.9 on Debian etch (stable), lists working fine except qrunner 
>silently dies and noone notices until someone realizes they haven't seen any 
>mail lately.  Currently worked around with cron job restarting Mailman. 
>Googling around, some have suggested this might be related to 

What's in Mailman's error and qrunner logs when the runner dies?

>Whether my perms are related to the above problem or not, I apparently do 
>have some permissions problems as shown by running check_perms.  There were 
>initially 70-some problems, most if not all of which were related to group 
>being root instead of list.  I ran check_perms -f (as root) and many, but 
>not all, were fixed.  Now there are 17 that still show having the same 
>problem - group root not list - and I can't seem to fix it.  Even using 
>WinSCP and trying to change the group ownership with that instead of 
>check_perms -f does not give lasting results.  IOW, I can't seem to change 
>the permissions!

What are the 17 problem files/directories and what are their ownership
and permissions?

>I'm not a Linux expert, obvious from the above...  Any suggestions?  Would 
>CHMOD from a server terminal be any different?

Probably not. It does essentially what check_perms does.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list