[Mailman-Users] Mail Processing Problem?

Brad Knowles brad at shub-internet.org
Sat Jan 12 23:58:09 CET 2008

On 1/12/08, Dennis Putnam wrote:

>  Thanks for the reply. I have a guess as to what is wrong but I don't
>  know how to fix it in mailman. Here are the syslog entries for a
>  non-mailman email:
>  Jan 12 10:55:10 dap002 postfix/qmgr[2345]: 47CD185063:
>  from=<dap at home.bellsouth.net>, size=435, nrcpt=1 (queue active)
>  Jan 12 10:55:16 dap002 postfix/smtp[21572]: 47CD185063:
>  to=<dap1 at bellsouth.net>, relay=mail.bellsouth.net[]:25,
>  delay=5.8, delays=0.05/0.02/5.5/0.28, dsn=2.0.0, status=sent (250 ok
>  ; id=20080112155515H0100n202se)
>  Jan 12 10:55:16 dap002 postfix/qmgr[2345]: 47CD185063: removed
>  Note the from hostname is 'home.bellsouth.net'. Now the mailman entries:

Clearly, the hostname is "dap002" in some domain, because that's the 
name that is showing up in the "hostnme" field in the syslog file.

>  Jan 12 10:56:12 dap002 postfix/qmgr[2345]: D4F7D85061:
>  from=<cufsalumni-bounces at dap002.bellsouth.net>, size=10015, nrcpt=1
>  (queue active)
>  Jan 12 10:56:12 dap002 postfix/smtpd[21582]: disconnect from 
>  Jan 12 10:56:16 dap002 postfix/smtp[21572]: D4F7D85061:
>  to=<dap1 at bellsouth.net>, relay=mail.bellsouth.net[]:25,
>  delay=3.5, delays=0.03/0.01/3.3/0.19, dsn=5.0.0, status=bounced (host
>  mail.bellsouth.net[] said: 550 [PERMFAIL] bellsouth.net
>  requires valid sender domain (in reply to RCPT TO command))

Well, if the hostname really was home.bellsouth.net, that would map 
to IP address, but the reverse DNS for this IP address 
points back to dsl.bellsouth.net, which does map correctly back to 
the same IP address.  So, I would not be surprised to see 
"home.bellsouth.net" changed to "dsl.bellsouth.net" in your outgoing 

>  Here the from hostname is 'dap002.bellsouth.net' instead of
>  'home.bellsouth.net', that is not to say I know this is the problem
>  but its all I can see as different.

Certainly, the name dap002.bellsouth.net does not exist in the DNS. 
If this is what your system is trying to use to identify itself to 
the outside world, that would be a problem.

>                                       Obviously mailman is somehow
>  overriding the normal from hostname and building its own. The name
>  'dap002' is the LAN hostname but I cannot use that as the from
>  address to my ISP. My ISP has a special hostname for situations like
>  this that will properly resolve via DNS although it is a dummy name
>  for all DHCP assigned IPs. My mm_cfg.py has these 2 lines referring
>  to the hostname but obviously they are not what is being used in this
>  case:

I suspect that the problem you're having may be a hostname or MTA 
misconfiguration issue, which Mailman is not involved in, and which 
cannot be fixed within Mailman.

Try typing the command "hostname" at the command-line prompt on the 
machine.  Also check your MTA configuration to make sure that this is 
not being over-ridden.

>  DEFAULT_EMAIL_HOST = 'home.bellsouth.net'
>  DEFAULT_URL_HOST = 'home.bellsouth.net'

If you made these changes after the list was created, then they will 
not be reflected in the list configuration.  I think that running 
"fix_url" will do that for you, but you'll have to check the FAQ 
Wizard or the archives of the list to be sure.

Brad Knowles <brad at shub-internet.org>
LinkedIn Profile: <http://tinyurl.com/y8kpxu>

More information about the Mailman-Users mailing list