[Mailman-Users] Message stuck in <list>.mbox after archive re-installation

Roger Price rprice at cs.uml.edu
Sun Jul 20 22:24:40 CEST 2008

My apologies in advance for such a noob question.  I run mailman on 
opensuse and I've just upgraded to opensuse 11.0 which provides 
mailman 2.1.9, postfix 2.5.1 and apache2 2.2.8.

Before the upgrade, I saved the archives of my club's slow moving 
mailing list.  I ran

cp -a <mailman>/archives/private/club <safe-place>/archives/private/club
cp -a <mailman>/lists/club            <safe-place>/lists/club

based on the mv's in 
http://wiki.list.org/viewpage.action?pageId=4030617 . After the 
upgrade and reinstallation of mailman, I created a new list "club", 
and then installed the archives.

cp -a <safe-place>/archives/private/club <mailman>/archives/private/club 
cp -a <safe-place>/lists/club            <mailman>/lists/club

I checked permissions and ownership with bin/check-perms, restarted 
mailman and postfix, visited my list with a browser and found my 
membership list, and past messages.  Then I sent a small message to 
the list.  I received a copy but none of the list members received 
it.  It sits in <mailman>/archives/private/club.mbox/club.mbox and 
doesn't get distributed.

Following the advice in 
I checked that mailmanctl is indeed running. The following qrunner's 
are reported by ps aux :

  /usr/lib/mailman/bin/qrunner --runner=ArchRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=BounceRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=CommandRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=IncomingRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=NewsRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=OutgoingRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=VirginRunner:0:1 -s
  /usr/lib/mailman/bin/qrunner --runner=RetryRunner:0:1 -s

Directory <mailman>/locks contains two files
where process 31638 is currently mailmanctl.

File mm_cfg.py contains SMTPHOST = "smtp.free.fr" which is correct 
for me.

File <mailman>/data/aliases contains a stanza of 10 lines for the 
"club" mailing list.  File /etc/postfix/main.cf contains

  alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases

Any hint for getting this hanging message out would be much 


More information about the Mailman-Users mailing list