[Mailman-Users] GPLv3

Barry Warsaw barry at list.org
Thu Jun 19 23:36:30 CEST 2008

Hash: SHA1

As you know, GNU Mailman has been an official GNU project for almost  
its entire life.

As such, our project receives certain benefits and has certain  
responsibilities.  One of our responsibilities is to adopt the  
standard GNU licensing regime.  This aligns with our goals for the  
project and so we do it gladly.

Last year, the Free Software Foundation released a significant update  
to the venerable GNU General Public License, called version 3 or  
GPLv3.  Recently, the FSF has been asking GNU projects in general, and  
GNU Mailman in particular to update to the GPLv3.  I think this is a  
good idea.  Briefly, compatibility with the Apache ASL 2.0 and the  
ability to exempt Python system libraries are two big benefits for us.

In talking with the FSF, we've agreed not to change Mailman 2.1 at  
all.  We will continue to release new Mailman 2.1 versions under the  
GPLv2, though hopefully after 2.1.11 there won't /be/ any more new 2.1  
releases ;).

Both Mailman 2.2 and 3.0 will be released under the GPLv3.  We've not  
made the changes to the source code yet, but we should do that soon.

I hope that you, our great Mailman community, will support this  
effort.  I don't think we need a big debate about the FSF, GNU or GPL  
here.  Long ago we committed to being a GNU project, and this is what  
the FSF wants all GNU projects to do.  I have less experience with the  
GPLv3 (as we all do!) but from my discussions and reading, I think the  
GPLv3 is a good license.  Please note that we are not planning to  
adopt the Affero GPLv3 even though Mailman has such a prominent web  

If you have a specific hardship with our adoption of GPLv3 for Mailman  
2.2 and 3.0, please let me know.  I may not be able to answer your  
questions, but we can bring in some official GNU and FSF people to  
help us address them.  I don't have a time frame for making the  
switch, but I'd like to do it soonish, and definitely before any next  
alpha release.

For more information, please see:


- -Barry

Version: GnuPG v1.4.9 (Darwin)


More information about the Mailman-Users mailing list