[Mailman-Users] Migrating list passwords when upgrading from 2.0.xto 2.1.x?

Christopher Waltham cwaltham at bowdoin.edu
Thu Mar 13 21:51:50 CET 2008

>>I just migrated a Mailman installation (~800 lists, ~5000 users) from 2.1.5 on SPARC Solaris to 2.1.9 on Linux x86. In the process, it looks like existing list passwords have become corrupted.

>>Is there an easy way to migrate those passwords across? I can't find anything in the FAQs, and really really don't want to have to give 800 list admins new passwords. :-(

>I'm confused. Your subject says 2.0.x to 2.1.x, but above you say 2.1.5
to 2.1.9.

Sorry Mark, you're right; this is 2.0.5 to 2.1.9. Apologies for the format of this email, too; Exchange webmail is awful.

>With a 2.0.x to 2.1.x migration, list admin and moderator passwords
will be lost. This is because the encryption algorithm changed, and
there is no way to decrypt the 2.0.x password and re-encrypt it for

Okay, that makes sense.

>In Mailman 2.1, there is a bin/change_pw script which can be used to
generate new list passwords and mail them to the list owners - the
list owners will have to assign new moderator passwords if any.

Thanks for the info! I might add this to the 2.0.x/2.1.y article in the FAQ so that other users are aware of this.


More information about the Mailman-Users mailing list