[Mailman-Users] Join List Problem

Bill Honneus (honneus) honneus at cisco.com
Tue May 6 22:32:33 CEST 2008

Hi Mark,

Ok, so now I ran ./configure and make install again the following
options set:


Then I restarted the mailmanctl with "bin/mailmanctl restart".

This time it looked like it tried to run the "join" script when I sent
an email request to the "test-join" alias, but I encountered the
following trace in /usr/local/mailman/logs/error:

May 06 16:22:42 2008 (21946) Uncaught runner exception: 'NoneType'
object has no attribute 'lower'
May 06 16:22:42 2008 (21946) Traceback (most recent call last):
  File "/usr/local/mailman/Mailman/Queue/Runner.py", line 114, in
    self._onefile(msg, msgdata)
  File "/usr/local/mailman/Mailman/Queue/Runner.py", line 185, in
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/usr/local/mailman/Mailman/Queue/CommandRunner.py", line 241, in
  File "/usr/local/mailman/Mailman/Queue/CommandRunner.py", line 139, in
    return handler.process(self, args)
  File "/usr/local/mailman/Mailman/Commands/cmd_subscribe.py", line 74,
in process
    if digest is None and password.lower() in ('digest', 'nodigest'):
AttributeError: 'NoneType' object has no attribute 'lower'

May 06 16:22:42 2008 (21946) SHUNTING:



-----Original Message-----
From: Mark Sapiro [mailto:mark at msapiro.net] 
Sent: Tuesday, May 06, 2008 3:08 PM
To: Bill Honneus (honneus); mailman-users at python.org
Subject: RE: [Mailman-Users] Join List Problem

Bill Honneus wrote:
>Now I am getting the following error:
>----- Forwarded Message ----
>From: Mail Delivery Subsystem <MAILER-DAEMON at my.domain.com>
>To: myAddress at yahoo.com
>Sent: Tuesday, May 6, 2008 1:11:04 PM
>Subject: Returned mail: see transcript for details
>The original message was received at Tue, 6 May 2008 13:11:04 -0400 
>from my-hostname.domain.com []
>  ----- The following addresses had permanent fatal errors ----- 
>"|/usr/local/mailman/mail/mailman join test"
>    (reason: 2)
>    (expanded from: <test-join at my.domain.com>)
>  ----- Transcript of session follows ----- Group mismatch error.  
>Mailman expected the mail wrapper script to be executed as group 
>"mailman", but the system's mail server executed the mail script as 
>group "mail".  Try tweaking the mail server to run the script as group 
>"mailman", or re-run configure, providing the command line option 
>554 5.3.0 unknown mailer error 2
>Reporting-MTA: dns; my.domain.com
>Received-From-MTA: DNS; my-hostname.domain.com
>Arrival-Date: Tue, 6 May 2008 13:11:04 -0400

>I tried to change the ownership of the symbolic link to mailman, but 
>that didn't seem to take:
>[root at 157226-mail smrsh]# chown :mailman mailman [root at 157226-mail 
>smrsh]# ls -l total 0 lrwxrwxrwx  1 root root 31 May  6 13:18 mailman 
>-> /usr/local/mailman/mail/mailman [root at 157226-mail smrsh]# =20

Ownership and permissions of the symlink itself are not relevant
anyway, since everything is determined by the target.

The group under which sendmail invokes the pipe (mail in this case)
comes from the sendmail config (sendmail.mc/sendmail.cf), but I'm not
a sendmail guy, so I can't tell you how to change it.

The alternitive is to rerun configure and make install with all options
as before except for the addition of --with-mail-gid=mail for


Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list