[Mailman-Users] Issues with sending messages to list

Mark Sapiro mark at msapiro.net
Wed Nov 19 16:37:12 CET 2008

Vikram Goyal wrote:
>I manage three announcement only lists. I had some issues with the server
>they were running on, because of which, I had to restart the server.
>However, since starting the server, I can't seem to be able to send any
>mails to any of the three lists.
>I checked the mail logs (/var/log/maillog), and the following entry was
>found for a test message send to the test list:
>"Nov 18 01:29:51 ip-XXXXX sendmail[13901]: mAI8ToHD013890:
>to="|/usr/local/mailman/mail/mailman post test", ctladdr=<test@****.com>
>(8/0), delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=33119, dsn=2.0.0,
>To me, this means that the mail was sent to the mailman process. (I have
>taken out the actual ip address and the domain for privacy reasons).

It means the mail was delivered to Mailman's mail wrapper which
presumably passed it to to Mailman's 'post' script which in turn would
place it in Mailman's in/ queue.

>So, why would the users on the test list not get the messages? 

Ith most likely reason is you don't have an init script to start
mailman so mailman isn't running and all the messages are just sitting
in Mailman's in/ queue.

You could look at the FAQ at <http://wiki.list.org/x/A4E9> for other

>Also, which log messages should I look for and rely on? The var/log/maillog
>or the log messages in the mailman directory?

Both, since the tell you about different steps in the process.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list