[Mailman-Users] Problem Migrating Mailman to New Server

Dennis Putnam dap1 at bellsouth.net
Sat Oct 25 14:32:39 CEST 2008

Mark Sapiro wrote:
>> OK, this is confusing. The public archive directories are links
>> (lrwxrwxrwx) to the private archive directories which contain the actual
>> archives. Those directories are drwxrwsr-x. The files are 755.
> If the files are 755, that's OK, but they aren't executable so they
> really should be 644.
Sorry. They are indeed 644. Brain was out to lunch.
> Yes, that's why I said "(was)". However, if CommandRunner is now 2773,
> it is likely that 2771 is another runner and was at the time. In any
> case, 2771 was the pid of the process that tried to create the lock.
> I asked, because I don't believe that the
> IOError: [Errno 13] Permission denied:
> '/var/lib/mailman/archives/private/mailman/database/2008-October-date.lock.dap002.2271.2'
> error came from your 'help' command mailed to -request. In any case,
> where did this error come from?. If it is in Mailman's error log,
> there should also be a traceback. What is that?
OK, now I understand what you are asking. I restarted mailman and let it
run for several minutes with no error in /var/log/mailman/error. Then I
submitted a help to -request. That is when the error occurred. I suppose
it might mot be the help request per se but rather anything that causes
mailman to do something. I tried to run a couple of other commands and
they all do the same thing. I am reluctant to actually send a test to
the list out of fear it might destroy something and make matters worse.
Here is the traceback.

Oct 24 17:30:09 2008 (5961) Uncaught runner exception: [Errno 13]
Permission denied:
Oct 24 17:30:09 2008 (5961) Traceback (most recent call last):
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 112, in _oneloop
    self._onefile(msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 170, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/usr/lib/mailman/Mailman/Queue/ArchRunner.py", line 73, in _dispose
  File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 216, in
  File "/usr/lib/mailman/Mailman/Archiver/pipermail.py", line 580, in
  File "/usr/lib/mailman/Mailman/Archiver/pipermail.py", line 632, in
    article.parentID = parentID = self.get_parent_info(arch, article)
  File "/usr/lib/mailman/Mailman/Archiver/pipermail.py", line 664, in
  File "/usr/lib/mailman/Mailman/Archiver/HyperDatabase.py", line 311,
in getOldestArticle
  File "/usr/lib/mailman/Mailman/Archiver/HyperDatabase.py", line 251,
in __openIndices
    t = DumbBTree(os.path.join(arcdir, archive + '-' + i))
  File "/usr/lib/mailman/Mailman/Archiver/HyperDatabase.py", line 61, in
  File "/usr/lib/mailman/Mailman/Archiver/HyperDatabase.py", line 77, in
  File "/usr/lib/mailman/Mailman/LockFile.py", line 243, in lock
  File "/usr/lib/mailman/Mailman/LockFile.py", line 422, in __write
    fp = open(self.__tmpfname, 'w')
IOError: [Errno 13] Permission denied:

Oct 24 17:30:09 2008 (5961) SHUNTING:

Here is the process (shouldn't this be running as 'mailman'?):

mail      5961  0.1  0.7  11100  7356 ?        R    17:28   0:00
/usr/bin/python /usr/lib/mailman/bin/qrunner --runner=ArchRunner:0:1 -s

Thanks for your patience and continued help.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 267 bytes
Desc: not available
URL: <http://mail.python.org/pipermail/mailman-users/attachments/20081025/c9d27ed1/attachment.pgp>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
URL: <http://mail.python.org/pipermail/mailman-users/attachments/20081025/c9d27ed1/attachment-0001.pgp>

More information about the Mailman-Users mailing list