[Mailman-Users] Apache does not have permission to access pipermail/listname

Lars Olson lars at vectortechnologies.ca
Sat Apr 11 05:36:26 CEST 2009

I am receiving an apache forbidden page when I try to access my archives
after moving my lists to a new server.  My old server was 2.1.8 – new server
is running 2.1.9 and using the same domain name.

Everything is working correctly except the archives... 

/etc/httpd/conf.d/mailman.conf has appropriate piper alias
--- cut here ---
Alias /pipermail/ /var/lib/mailman/archives/public/
<Directory /var/lib/mailman/archives/public>
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
--- end cut here ---

- Permissions on public archives directory is drwxrwsr-x with symlinks to
private lists
- Permissions on private archives directory is drwxrws--x with directories
below as drwxrwsr-x
- Files within the private folder are world readable with -rw-rw-r--
- I ran the bin/arch script (/usr/lib/mailman/bin/arch listname
- I ran the withlist script to verify permissions are correct (./withlist -l
-r fix_url listname)

Don't know what else to try.  Haven't found anything in the FAQ or the
Mailman archives.  I have tried reading the documentation labyrinth but that
hasn't helped so far - I'm thinking I need a new direction, a new path to
follow - been looking at this too long... 

Looking for some help at this point.

This email message has been scanned for viruses before being sent to you and
found to be
Checked by AVG - www.avg.com 
Version: 8.0.238 / Virus Database: 270.11.49/2050 - Release Date: 04/10/09

More information about the Mailman-Users mailing list